How to get injection working with zd1211 chipset (zydas)

all kinds of tutorials and guides. how, where, why, step-by-step stuff and more. also support for those tutorials and guides. ONLY post step-by-step guides/tutorials here OR reply with question if you have any.

How to get injection working with zd1211 chipset (zydas)

Postby Sethioz » Tue Mar 23, 2010 11:39 pm

This tutorial teaches you how you can get injection working with A-Link USB adapter that uses zd1211 chipset. chipset name can be different, it may also say "zydas 1211". this is what zd stands for "zydas"

1. download compat-wireless drivers 2.6
2. download zd1211 / zydas 1211 driver injection patch
3. unpack both into same folder
4. browse into the directory where you unpacked them (using console ofcourse) (make sure that patch is in the root directory of drivers)
5. now apply the patch with the following command:

Code: Select all
patch -Np0 -i patch_file_name_here


example if you have not renamed the patch file:

Code: Select all
patch -Np0 -i zd1211rw-inject+dbi-fix-2.6.26.patch


6. type "make" however you should skip this step
7. type "make install" note that it might take quite a long (5 mins or so).

you are done, reboot and it should work, if not, then try these steps:

8. type "make unload" in order to unload the old driver
9. type "modprobe zd1211rw" to load the new driver

most likely you do not need steps 8 and 9, worked without those for me, i only rebooted and worked.
User avatar
Sethioz
Admin
Admin
 
Posts: 4757
Joined: Fri Jul 27, 2007 5:11 pm
Location: unknown

Return to Tutorials / Guides

Who is online

Users browsing this forum: No registered users and 1 guest