BackTrack - fixing black screen issue after startx command

all kinds of tutorials and guides. how, where, why, step-by-step stuff and more. also support for those tutorials and guides. ONLY post step-by-step guides/tutorials here OR reply with question if you have any.

BackTrack - fixing black screen issue after startx command

Postby Sethioz » Sun Oct 21, 2012 9:22 am

This tutorial explains how to fix the issue with black / blank screen appearing after "startx" command is entered.
It happend to me after upgrading from Backtrack 5 RC2 to RC3 on old laptop using intel graphics.
as far as i know, it is because graphics driver or something similar.
It took me 2 days to figure this out, because people just suck at writing tutorials, they mumble and blabber about things, but there is NO step by step, they say bla bla change grub bla bla add this, but HOW the hell am i suppouse to do any of that, if i can't even boot up GUI ? i can't edit files via cmd, or can i ?
so here is full tutorial on how to fix this issue and how to get access to those files.

1. if you are running live cd/usb, then you can press "tab" during boot menu and it gives you option to edit grub, but in my case i do not use live cd/usb. i have it installed on hdd.

2. in order to access your backtrack partition, you need Ext2Fsd (assuming you have windows installed on same machine)
- if you don't have windows installed, tough shit. you need to either take out your HDD and mount it via other pc and adapter
- or you have to get live version of linux / backtrack and do it via that

3. If you are using windows and Ext2Fsd
- install ext2fsd
- reboot
- see if it auto-assigned drive letters, if not, do it manually (its straight forward if you just follow the on screen text)
- most likely it is read only mounted, so you have to change it
- open ext2fsd main windows (if its in tray, right click show main window)
- right click on the mounted linux partition
- show properties
- ext2 properties
- uncheck the box "mount volume in readonly mode"
- ignore the message that says you need to reboot (if it comes up)
- now you can edit that partition
- go to your computer
- enter the partition

4. go to location

Code: Select all
/etc/default/

open "grub" file with notepad++ (or any text editor)

find this line:
Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT=


value between " " should be something like "text splash vga=791" it can also be "vga = 791 splash text" or similar. doesn't really matter, as long as you are in right place.
add the following after that:

Code: Select all
i915.modeset=1


in case i confused you, here's full example how it should look like after editing:

Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT="text splash vga=791 i915.modeset=1"


save the file and reboot into backtrack and try. if it doesn't work, follow next steps.

5. go to location:

Code: Select all
/boot/grub/


and open "grub.cfg" with notepad++ or any other text editor

do same in that file. find "vga=791" (if value in grub file was different, then search for that instead!)
add i915.modeset=1 after vga=791. there are 2 instances, so you must do both of them.
note, that grub.cfg is DIFFERENT from grub file and there are no quotes (" " like these) around the values.
simply put one space after vga=791 and add the line.
here's full example how it should look like after editing:

Code: Select all
text splash vga=791 i915.modeset=1


again, keep in mind that it might also be that text splash appears after vga=791 ..etc. does not matter, just add i915.modeset=1 after whatever is last there.
save the file
reboot into backtrack.

if it did not work, you either did something wrong or you have other issue.
User avatar
Sethioz
Admin
Admin
 
Posts: 4753
Joined: Fri Jul 27, 2007 5:11 pm
Location: unknown

Return to Tutorials / Guides

Who is online

Users browsing this forum: No registered users and 2 guests

cron