How to disable monitor hotplug / auto detection in windows

all kinds of tutorials and guides. how, where, why, step-by-step stuff and more. also support for those tutorials and guides. ONLY post step-by-step guides/tutorials here OR reply with question if you have any.

How to disable monitor hotplug / auto detection in windows

Postby Sethioz » Fri Jul 15, 2016 3:58 am

Well not exactly a tutorial yet, but this issue has been annoying a lot of people over lot of years, ever since microSHIT introduced this "feature" in windows 7, everyone has been pissed off over it.
Namely .. if you have more than 1 monitor, powering off 1 monitor that is connected over HDMI or DisplayPort (or laptop monitor) will cause all the icons and apps being squashed onto secondary monitor, this happens because windows thinks that you have disconnected the monitor entirely.
It's very irritating and pisses off everyone who has been using multi monitors on windows 7 or later.

I've googled like crazy, yet there's no actual solution to this. AMD video cards seem to have setting in their control panel, where you can set your monitor as "always on" and this seem to fix it, but for nVidia users .. there's no fix.
Also some monitors come with specific drivers that have option to disable / bypass this, but again, only some.
On laptops, there should be some sort of registry tweak, but anyone who owns a PC with nVidia card, there's no fix.

So i've been looking deeper into the issue and I will keep updating this topic with what I find.

I decided to narrow it down to see WTF is causing this idiocy. I'm using Procmon64 (process monitor 64 bit), which is freely available, just google for it.
So i've filtered out things by Path and Process name, for example i know for a fact that Skype.exe has nothing to do with this, so i've excluded skype.exe completely, i did same with all running programs, however you can't exclude things like "system" or "explorer.exe" as those might be responsible for the thing happening. So rest I slooowllyyy excluded by path. I let it run for few seconds, stopped it, then highlight all > exclude path.
I got it up to a point where nothing popped up for a good 30 seconds, then I turned my monitor off (by pressing the physical power button on monitor) and then back on, I got lot of shit popping up, too much to go through in short time, but I already saw lot of interesting stuff there.

So as soon as I hit the button, windows detected that something is going on with monitor, it checks for resolution, position ..etc. Most of the things that popped up were registry entries, but they're very clear ... this is what is going on.

Then I noticed that EXPLORER.exe accesses all my desktop icons too when i power monitor on / off. So I killed explorer.exe process and powered my monitor on / off again. SURPRISE! all my icons were exactly where I left them, so now I know that explorer.exe is what fucks up the icons. However all the apps still bunched onto other monitor.

I'm gonna play around with the procmon logs a bit more and see if I can block that bastard "feature" once and for all. At this point .. I just have no idea how to block such windows event, there must be a tool for it.

Here's a screenshot of some interesting things that windows 10 accesses when you power monitor on / off.
snipz.JPG




Additionally it's possible to tape the hotplug pin on your HDMI cable, however it doesn't work for DisplayPort cable on some reason, but that's no fucking fix! Sometimes i wanna use different monitor, taping each cable is total bullshit. I might, but I use DisplayPort as my primary monitor only supports 4k 60fps over DisplayPort, HDMI will get me 30fps. so it's a no go anyway.
User avatar
Sethioz
Admin
Admin
 
Posts: 4742
Joined: Fri Jul 27, 2007 5:11 pm
Location: unknown

Return to Tutorials / Guides

Who is online

Users browsing this forum: No registered users and 1 guest

cron