360 Controller (PC) Code 28 (drivers missing)

Detailed explainations of errors/bugs. cause and fix (if any). also support for your problems here.

360 Controller (PC) Code 28 (drivers missing)

Postby Sethioz » Tue Jan 26, 2016 8:31 am

Today my Razer ONZA 360TE controller just stopped working for no reason, all the lights turned off and it was not being detected on my windows. I re-connected the controller, lights popped up for about 5 seconds and then it turned off again.
I tried in other pc and it worked fine. so clearly issue was with software.

Just a note, that it's same as default 360 controller, Razer one just has some extra buttons (that work on hardware level) and slightly different shape and better grip on analogs, so if you have default 360 controller, the solution could be same.

So I WASTED like 1 hour on trying to figure out wtf is going on, i checked in device manager and it said that Driver could not be installed, error code 28.
I have windows 10, but same issue could happen on any windows really. windows has 360 drivers by default, there's no such thing as "360 controller driver" for windows, it's a default device, such as mouse and keyboard that are being detected by default.

Solution was rather "easy"

- Unplug the controller
- go into device manager
- view > show hidden devices
- find the stupid 360 controller (most likely it has a ! mark next to it and it's extended already)
- right click > uninstall > click ok if asked
- reboot your pc (do not plug the controller in)
- now download "ccleaner" if you don't already have it (you can get it from filehippo.com)
- run ccleaner and enable all the options (apart from "wipe free space"), but use common sense, if you have stored passwords in browsers, then most likely you don't want to wipe those, but i recommend using ALL options.
- now in ccleaner, do same with registry cleaner, enable ALL options (no exceptions) and run it, then click fix all errors.
- now reboot PC again
- wait for your PC to boot up properly, wait until all your start-up apps are being loaded ..etc
- now plug your 360 controller back in pc and it should work (might take 5-15 seconds for it to work, but should work instantly).

If this doesn't help, then no idea. try in other PC, if it works in other PC, then you still have some software conflict.
Software such as PS3 controller drivers or vJoy drivers may conflict and prevent it from working, but in my case it stopped working in middle of the game .. ..so clearly the FUCKING GAYDOWS PIECE OF SHIT DID SOMETHING TO ITSELF AND FUCKED ITSELF TOO HARD! ... it just pisses me off so bad when windows does some shit on background and jacks up my stuff for no reason ... FFS I WAS PLAYING !!!!!!!!!!!!!!! why fuck itself on the background and then poop up my controller ... senseless.


UPDATE: Mine doesn't work in USB3.0 port anymore, It used to work, but now it doesn't like USB 3.0 ports anymore, so if you're is plugged into a USB3.0 port (or a hub that is plugged in USB3.0), then try using it in USB2.0 port instead. It shouldn't be an issue, but with microsoft windows .. you never know. Maybe windows did something with USB3.0 drivers and screwed it up .. no idea. Other USB2 devices work fine in USB3. USB3.0 is backwards compatible, so no idea wtf the issue is, but it keeps stopping in USB3 ports.
User avatar
Sethioz
Admin
Admin
 
Posts: 4757
Joined: Fri Jul 27, 2007 5:11 pm
Location: unknown

Return to Errors / Crashes / Bugs / Support / Help

Who is online

Users browsing this forum: No registered users and 2 guests