External HDD / device not working in eSATA / pink USB

Detailed explainations of errors/bugs. cause and fix (if any). also support for your problems here.

External HDD / device not working in eSATA / pink USB

Postby Sethioz » Sun Jan 20, 2013 3:13 am


See the NOTE below!

This is about eSATA powered USB ports not being able to detect external HDD / hard drives / other devices using eSATA / USB3.0
- eSATA device not detected
- windows 7 not being able to detect eSATA hard drive / device
- Powered eSATA/USB (pink USB) port does not detect external hard drive / disk / hdd

These are just keywords for people who are having similar issues and search different things. so they find solution.

So my problem was that i bought 3TB External HDD that uses USB3.0, however my motherboard does not have USB3.0. my only solution was to connect it into one of those pink USB ports at back. on other motherboards it might not be pink, but in manual it is described as "Powered eSATA/USB" ports.
As far as i understand, eSATA devices fit into same port, but it also supports USB

Bug / Error / Crash / Issue
- When USB3.0 and/or eSATA device is plugged in, nothing happens. device is not detected by windows
- Device does not show up anywhere, not in device manager or anywhere else

First i must say, this is very tricky and frustrating process that took me about 5 hours to figure it out.
one fix lead to another problem .. so i had to sort them out one by one.

Problem 1:
- your "SATA Connection Type" is set to RAID or IDE in BIOS

Fix 1: (not recommended to do it in this order, follow Fix 2 first)
- boot into your bios (usually you get into BIOS by pressing DEL key during bootup or pressing it many times during boot, if DEL doesn't work, wait for computer to start booting and see which key goes into BIOS, it always tells you on startup screen)
- Locate the SATA Connection Type, it is different for each motherboard. Probably it is under advanced somewhere.
- you easily know if its right place, because it has only 3 options (maybe more)
- Set it to "AHCI"
- Save and reboot

Problem 2:
- This occurs in Windows 7 for sure (maybe in other windows too, not tested)
- Now problem is that Windows 7 will instantly crash with BSOD and not giving any error code, just blue screen saying there is problem with hard drive/s
- Right, so you as said, you must follow Fix for this first.

Fix 2:
- Change it back from "AHCI" to "IDE"
- boot into your windows (if your HDD order gets fucked up in process, just re-order them in bios or use boot menu > see keys during start up)
- now go to "start"
- enter "regedit" and hit enter
- go to HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlset/Services/msahci
- on the right, locate "start"
- right click "start" and select "modify" (or double click on "start"
- now in the value box, write "0" (no quotes). default value should be 3
- reboot into BIOS, change "IDE" to "AHCI" again
- reboot again, now windows should boot up normally without crashing

Now after these 2 steps, windows will recognize the eSATA external device and starts to install drivers

Problem 3: (might not occur)
- in my case, windows did install drivers and called my HDD by name, but still did not show up

Fix 3:
- Usually motherboards have 2x eSATA USB ports
- simply unplug your hdd and plug it into other eSATA USB port (or just eSATA)
- if you have only one eSATA powered USB / eSATA port try rebooting again.
- if it still doesn't see your drive, you must now uninstally the drivers for AHCI, not sure how to do it tho, in device manager somewhere, then re-install drivers without plugging in your drive, then reboot, plug-in drive

If none of this fixes your issue, post here and i try to help you out, HOWEVER before you panic out, make sure your drive even works. try other PC or in my case, i plugged it into USB2.0 and it worked just fine.

NOTE: This does NOT increase the device speed beyond USB2. Power eSATA / USB combo / hybrid port is either eSATA or USB2, not both, it does not combine USB into eSATA, so USB3 device will not get the USB3 or eSATA speeds out of that port.
Power eSATA/USB port is USB2 one side and eSATA other side, so if you plug USB2/3 into that port, it will be at USB2 speeds. you would need adapter that doesn't seem to exist to get eSATA / USB3 kind speeds out of it.

If you trying to use USB3.0 in eSATA, don't bother. get USB3.0 adapter. I got 40mb/s read/write out of USB2 port, but now that i have PCI-E USB 3.0 adapter, that same HDD pulled 190mb/s read/write (yes both speeds are nearly same).
User avatar
Posts: 4763
Joined: Fri Jul 27, 2007 5:11 pm
Location: unknown

Return to Errors / Crashes / Bugs / Support / Help

Who is online

Users browsing this forum: No registered users