cmd not working commands

Detailed explainations of errors/bugs. cause and fix (if any). also support for your problems here.

cmd not working commands

Postby Legu » Thu Dec 06, 2012 11:35 am

Allright, i updated my zenframework (php), and after i did it, i wanted to check my ip. It didnt work....if i hit the windows button and type cmd in the searchfield, and hit enter, the cmd window pops up like always, but when i try to use commands, they dont work. And that is the tricky part...some commands work...like

-- cd
-- rd
-- mkdir
...

commands that dont work for example:

systeminfo
taskkill
help
ipconfig
....

Any ideas?
Image


(Also: if i run the cmd window from system32, manually, it works....)
Attachments
screen.JPG
User avatar
Legu
Allie
Allie
 
Posts: 232
Joined: Sun Dec 18, 2011 6:47 pm

Re: cmd not working commands

Postby Sethioz » Thu Dec 06, 2012 12:47 pm

systeminfo and help are not even commands.
you have completely wrong understanding of cmd.
if ipconfig doesn't work, but when ran manually it works, it means your windows is fucked up. you have some permission issues.

you have to first learn what cmd really is. only commands you have, are things like "cd" "cd .." "dir" "del" "ren" ..etc
help, systeminfo, ipconfig ..etc are not commands at all. cmd works fine, its your windows that doesn't work. things are missing or blocked.
User avatar
Sethioz
Admin
Admin
 
Posts: 4755
Joined: Fri Jul 27, 2007 5:11 pm
Location: unknown

Re: cmd not working commands

Postby Legu » Thu Dec 06, 2012 6:30 pm

Okay then what can cause this kind of problem?
User avatar
Legu
Allie
Allie
 
Posts: 232
Joined: Sun Dec 18, 2011 6:47 pm

Re: cmd not working commands

Postby KEN » Thu Dec 06, 2012 7:16 pm

Legu wrote:Okay then what can cause this kind of problem?

missing windows files or the files being blocked.
See if something is blocking them and try a windows repair maybe.
User avatar
KEN
Moderator
Moderator
 
Posts: 756
Joined: Thu Jan 28, 2010 8:11 am


Return to Errors / Crashes / Bugs / Support / Help

Who is online

Users browsing this forum: No registered users and 3 guests